import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:<[^>]*>[^<]*?)*?(?:(?!<mark>)<[^>]*(?=>))?)(\\W|^)(eiusmod|sort|incididunt|dolor|única|feté)(?=\\W|$)";
final String string = "única<div data-sort=\"1\">\n\n"
+ "<p>dolor</p>\n"
+ "<p>única</p>\n\n"
+ "<h1 data-position=\"1\" eiusmod=\"foo\" >Lorem ipsum dolor sit amet</h1>\n"
+ "<div data=\"eiusmod\"></div>\n"
+ "<strong>search here : consectetur adipiscing elit, </strong>\n"
+ "<div>\n"
+ "sed do <u>eiusmod</u> tempor <mark>incididunt</mark> ut dolor et dolor dolor magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.\n"
+ "</div>\n"
+ "Duis aute irure <i>dolor</i> dolor in dolor dolor reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.\n"
+ "</div>\n\n"
+ "<div>\n"
+ "sed do <u>eiusmod</u> tempor <mark>incididunt</mark> ut única et única púnica magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.\n"
+ "</div>\n"
+ "<div>fetén</div>\n\n\n\n";
final String subst = "\\1\\2<mark>\\3</mark>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}