package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^:]+?)\s*:\s*([^\s|]+)`)
var str = `[xx] Guidance) Boundary: 123 | Total: 1010 | Steps Count test: 21 | initial value Count: 19`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}