re = /([^:]+?)\s*:\s*([^\s|]+)/
str = '[xx] Guidance) Boundary: 123 | Total: 1010 | Steps Count test: 21 | initial value Count: 19'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end