const regex = /Change:\s*\<a href\=\"(?<change_url>[^\"]*)\"\>(?<change>[^\<])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Change:\\s*\\<a href\\=\\"(?<change_url>[^\\"]*)\\"\\>(?<change>[^\\<])', 'gm')
const str = `Change: <a href="https://xxyyzz.com/changes/12345">#12345</a> - Review: <a href="https://xxyyzz.com/reviews/7890">#7890</a>
Change: <a href="https://xxyyzz.com/changes/1345">#1345</a> - Review: <a href="https://xxyyzz.com/reviews/7891">#7891</a>
Review: <a href="https://zzyyyxxx/reviews/205657">205657</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}