$re = '/Change:\s*\<a href\=\"(?<change_url>[^\"]*)\"\>(?<change>[^\<])/m';
$str = 'Change: <a href="https://xxyyzz.com/changes/12345">#12345</a> - Review: <a href="https://xxyyzz.com/reviews/7890">#7890</a>
Change: <a href="https://xxyyzz.com/changes/1345">#1345</a> - Review: <a href="https://xxyyzz.com/reviews/7891">#7891</a>
Review: <a href="https://zzyyyxxx/reviews/205657">205657</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);