$re = '/\G(?=.*{[^{}]*}\z)({[^{}]*})([+*\/-])?/m';
$str = '{value1}+{value2}-{value3}*{value...n}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);