re = /\G(?=.*{[^{}]*}\z)({[^{}]*})([+*\/-])?/m
str = '{value1}+{value2}-{value3}*{value...n}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end