const regex = new RegExp('.{1,}?([。.」??!!]+|\\n)', 'gmiu')
const str = ` そこは純白の空間だった。
四方の壁は継ぎ目の無い白塗り、中央に鎮座する祭壇も雪を固めたように真っ白で、この部屋を満たす光もまた白く輝いていた。
「供物を捧げよ」
どこからとも無く部屋中に響き渡る声。
開け放たれた両開きの扉、その暗い通路の向こうから人の列がやってくる。白い部屋と同じように、その人々もまた白尽くめであった。
染み一つ無い清潔な白いローブで全身を覆い、顔には白いマスクを被り、素肌を露出している部分が一切無い。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}