package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w|'[^']*')+`)
var str = `this-string 'has only three tokens'
this*string'has only two@tokens'
one'two''three' '' four 'twenty-one'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}