$re = '/(?:\w|\'[^\']*\')+/m';
$str = 'this-string \'has only three tokens\'
this*string\'has only two@tokens\'
one\'two\'\'three\' \'\' four \'twenty-one\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);