$re = '/(\[.*?\])/m';
$str = '\'([Total Revenue] + [COGS] + [Distribution Costs] + [Sales Force Costs] + [A&P Costs] + [NDA Affairs Costs] + [Other Operating Costs]) * - [NDA share]\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);