re = /(\[.*?\])/m
str = '\'([Total Revenue] + [COGS] + [Distribution Costs] + [Sales Force Costs] + [A&P Costs] + [NDA Affairs Costs] + [Other Operating Costs]) * - [NDA share]\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end