package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*[+-]?(0|[1-9][0-9]*)([Ee][+-]?[0-9]+)?\s*$`)
var str = `0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}