$re = '/^\s*[+-]?(0|[1-9][0-9]*)([Ee][+-]?[0-9]+)?\s*$/m';
$str = '0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);