using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<_KEY_1>\w+)(?=\.nomv="")|(?<_VAL_1>(?<=\.nomv="")[A-Za-z ]+|(?<=\|\|\|)[A-Za-z ]+)";
string input = @"page_name=""xxx.com"", page_type=other, thread_id=1152236, geo_locality.nomv=""Seattle|||San Francisco|||Chicago"", user_reference_count=0,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}