# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<_KEY_1>\w+)(?=\.nomv=\")|(?<_VAL_1>(?<=\.nomv=\")[A-Za-z ]+|(?<=\|\|\|)[A-Za-z ]+)"
test_str = "page_name=\"xxx.com\", page_type=other, thread_id=1152236, geo_locality.nomv=\"Seattle|||San Francisco|||Chicago\", user_reference_count=0,"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.