using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(?:$|\/)";
string input = @"https://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
https://www.website.com/catalog/trinkets/item/1772/
https://www.website.com/catalog/1772
http://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
http://www.website.com/catalog/trinkets/item/1772/
http://www.website.com/catalog/1772
https://website.com/catalog/trinkets/item-news-standart-formy/1772/
https://website.com/catalog/trinkets/item/1772/
https://website.com/catalog/1772
возвращяются групаа первая вторая и третяя
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}