$re = '/(\d+)(?:$|\/)/m';
$str = 'https://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
https://www.website.com/catalog/trinkets/item/1772/
https://www.website.com/catalog/1772
http://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
http://www.website.com/catalog/trinkets/item/1772/
http://www.website.com/catalog/1772
https://website.com/catalog/trinkets/item-news-standart-formy/1772/
https://website.com/catalog/trinkets/item/1772/
https://website.com/catalog/1772
возвращяются групаа первая вторая и третяя
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);