using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?\d{0,2})?\s?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$";
string input = @"1
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890
+1234567890
+123-456-7890
+123 456 7890
123 456 7890
123-456-7890
123 456-7890
123-456 7890
123-4567890
123456-7890
(234) 567 8940
(234)-567-8490
(425)512-7497
+919560862817
9560862817
956 086 2817
sgsdfgsd sdgsd sdg
asdf
+448897687877
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}