# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+?\d{0,2})?\s?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$"
test_str = ("1\n"
"12\n"
"123\n"
"1234\n"
"12345\n"
"123456\n"
"1234567\n"
"12345678\n"
"123456789\n"
"1234567890\n"
"+1234567890\n"
"+123-456-7890\n"
"+123 456 7890\n"
"123 456 7890\n"
"123-456-7890\n"
"123 456-7890\n"
"123-456 7890\n"
"123-4567890\n"
"123456-7890\n"
"(234) 567 8940\n"
"(234)-567-8490\n"
"(425)512-7497\n"
"+919560862817\n"
"9560862817\n"
"956 086 2817\n"
"sgsdfgsd sdgsd sdg \n"
"asdf\n"
"+448897687877\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.