package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\\]+\.sav)`)
var str = `C:\Users...\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\AutumnHi-20180531-183047-34-SystemNormal\AutumnHi-20180531-183047-34-SystemNormal.sav`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}