re = /([^\\]+\.sav)/m
str = 'C:\\Users...\\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\\AutumnHi-20180531-183047-34-SystemNormal\\AutumnHi-20180531-183047-34-SystemNormal.sav'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end