#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Abstract title:(?:.|\r?\n\w)*"
Local $sString = "Prof. Imperdiet montes, metus elementum eleifend eget eget adipiscing augue." & @CRLF & _
"Abstract title: Lorem ipsum dolor sit amet, consectetuer adipiscing" & @CRLF & _
"" & @CRLF & _
"A, nec, quam eleifend quis, magnis sit pretium. leo augue. amet, elit. vel" & @CRLF & _
"" & @CRLF & _
"Vel, dis eget nascetur justo. imperdiet consequat et sit Nam Aenean a, Quisque" & @CRLF & _
"Enim. a, dui. Aenean lorem Phasellus commodo quis, pretium ultricies nascetur" & @CRLF & _
"tincidunt. sem. vitae," & @CRLF & _
"montes, tellus. amet, venenatis natoque enim. fringilla" & @CRLF & _
"quis, vitae, Aenean Etiam viverra ipsum dapibus ut elementum Aenean Lorem eget," & @CRLF & _
"nisi mollis Curabitur Quisque Aenean rhoncus sociis justo, sem. justo, vel" & @CRLF & _
"Aenean ultricies nec, eu laoreet." & @CRLF & _
"" & @CRLF & _
"Dr. Enim. vitae, feugiat in, Aenean" & @CRLF & _
"Abstract title: Massa. sociis dis dapibus dolor semper ipsum" & @CRLF & _
"jalor" & @CRLF & _
"" & @CRLF & _
"Semper tincidunt. ullamcorper commodo magnis viverra pede elit. eget aliquet" & @CRLF & _
"eleifend vel, eleifend feugiat pede Vivamus ridiculus vitae, a, ligula, et Nulla" & @CRLF & _
"ligula vulputate ac, nisi. enim dapibus. Donec metus In sit dolor Nam ultricies" & @CRLF & _
"imperdiet. pellentesque Cras eu, massa quis porttitor parturient varius ut," & @CRLF & _
"Phasellus arcu. pretium. quam augue. eu, adipiscing felis, enim. ante," & @CRLF & _
"vulputate Integer dui. ultricies a, dictum rutrum. Nullam nec, quis," & @CRLF & _
"consequat Cum tellus. dis felis dolor. nulla Aliquam Donec massa. justo. in," & @CRLF & _
"nascetur" & @CRLF & _
"Semper tincidunt. ullamcorper commodo magnis viverra pede elit. eget aliquet" & @CRLF & _
"eleifend vel, eleifend feugiat pede Vivamus ridiculus vitae, a, ligula, et Nulla" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Dr. Justo. nisi elementum ante, Donec Aenean Nulla" & @CRLF & _
"Abstract title:" & @CRLF & _
"" & @CRLF & _
"Aenean consectetuer leo penatibus eget imperdiet nisi. consequat" & @CRLF & _
"lorem pretium mus. " & @CRLF & _
"" & @CRLF & _
"Prof. Dr. Aliquam metus semper" & @CRLF & _
"Abstract title: Aliquet augue. amet, enim ut justo, nec, eleifend lorem enim. nisi. ipsum" & @CRLF & _
"eleifend" & @CRLF & _
"More information will be available soon."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")