# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Abstract title:(?:.|\r?\n\w)*"
test_str = ("Prof. Imperdiet montes, metus elementum eleifend eget eget adipiscing augue.\n"
"Abstract title: Lorem ipsum dolor sit amet, consectetuer adipiscing\n\n"
"A, nec, quam eleifend quis, magnis sit pretium. leo augue. amet, elit. vel\n\n"
"Vel, dis eget nascetur justo. imperdiet consequat et sit Nam Aenean a, Quisque\n"
"Enim. a, dui. Aenean lorem Phasellus commodo quis, pretium ultricies nascetur\n"
"tincidunt. sem. vitae,\n"
"montes, tellus. amet, venenatis natoque enim. fringilla\n"
"quis, vitae, Aenean Etiam viverra ipsum dapibus ut elementum Aenean Lorem eget,\n"
"nisi mollis Curabitur Quisque Aenean rhoncus sociis justo, sem. justo, vel\n"
"Aenean ultricies nec, eu laoreet.\n\n"
"Dr. Enim. vitae, feugiat in, Aenean\n"
"Abstract title: Massa. sociis dis dapibus dolor semper ipsum\n"
"jalor\n\n"
"Semper tincidunt. ullamcorper commodo magnis viverra pede elit. eget aliquet\n"
"eleifend vel, eleifend feugiat pede Vivamus ridiculus vitae, a, ligula, et Nulla\n"
"ligula vulputate ac, nisi. enim dapibus. Donec metus In sit dolor Nam ultricies\n"
"imperdiet. pellentesque Cras eu, massa quis porttitor parturient varius ut,\n"
"Phasellus arcu. pretium. quam augue. eu, adipiscing felis, enim. ante,\n"
"vulputate Integer dui. ultricies a, dictum rutrum. Nullam nec, quis,\n"
"consequat Cum tellus. dis felis dolor. nulla Aliquam Donec massa. justo. in,\n"
"nascetur\n"
"Semper tincidunt. ullamcorper commodo magnis viverra pede elit. eget aliquet\n"
"eleifend vel, eleifend feugiat pede Vivamus ridiculus vitae, a, ligula, et Nulla\n\n\n"
"Dr. Justo. nisi elementum ante, Donec Aenean Nulla\n"
"Abstract title:\n\n"
"Aenean consectetuer leo penatibus eget imperdiet nisi. consequat\n"
"lorem pretium mus. \n\n"
"Prof. Dr. Aliquam metus semper\n"
"Abstract title: Aliquet augue. amet, enim ut justo, nec, eleifend lorem enim. nisi. ipsum\n"
"eleifend\n"
"More information will be available soon.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.