#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(T|t)(id)?ak"
Local $sString = "Kenangan itu cuma hantu di sudut fikir, selama kita cuma diam, selamanya dia tetap jadi hantu. Ga akan pernah jadi kenyataan" & @CRLF & _
"" & @CRLF & _
"Saya ngga mungkin begini terus, melepas kepergian kamu, tanpa tahu kapan kamu akan kembali dan apakah kamu mau kembali" & @CRLF & _
"" & @CRLF & _
"Saya ngga mungkin begini terus, melepas kepergian kamu, tanpa tahu kapan kamu akan kembali dan apakah kamu mau kembali" & @CRLF & _
"" & @CRLF & _
"Tak seusia, bukan berarti tak sesuai" & @CRLF & _
"" & @CRLF & _
"Tak perlu dua, cukup dia" & @CRLF & _
"" & @CRLF & _
"Milea, kamu cantik, tapi aku belum mencintaimu, nggak tahu kalau sore. Tunggu aja" & @CRLF & _
"" & @CRLF & _
"Cemburu itu hanya untuk orang yang nggak percaya diri. Dan sekarang aku sedang tidak percaya diri" & @CRLF & _
"" & @CRLF & _
"Cinta Tidak Bisa Dipaksakan, Merelakannya Pergi Jauh Lebih Baik Daripada Menggenggamnya Tanpa Cinta" & @CRLF & _
"" & @CRLF & _
"Ketika Tuhan mengambil sesuatu dari genggamanmu, Dia tak menghukummu, namun hanya membuka tanganmu tuk menerima yang lebih baik" & @CRLF & _
"" & @CRLF & _
"Tidak penting saya berasal dari mana, tapi saya tahu kemana tujuan saya" & @CRLF & _
"" & @CRLF & _
"Tuhan tidak pernah menciptakan produk gagal" & @CRLF & _
"" & @CRLF & _
"Hanya orang bodoh yang mau kembali ke kebodohannya dan meninggalkan masa depannya" & @CRLF & _
"" & @CRLF & _
"Ketika kita memimpin orang lain, kita lupa bertanya apakah kita sudah bisa memimpin diri sendiri" & @CRLF & _
"" & @CRLF & _
"Sikap toleransi akan membingkai semua perbedaan dengan sempurna" & @CRLF & _
"" & @CRLF & _
"Kamu bisa aja pergi dari masalah, tapi masalah tidak akan hilang dari hidup kamu" & @CRLF & _
"" & @CRLF & _
"Apa gunanya punya pikiran sendiri, kalo lo selalu percaya ama pikiran orang"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")