const regex = /(T|t)(id)?ak/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(T|t)(id)?ak', 'gm')
const str = `Kenangan itu cuma hantu di sudut fikir, selama kita cuma diam, selamanya dia tetap jadi hantu. Ga akan pernah jadi kenyataan
Saya ngga mungkin begini terus, melepas kepergian kamu, tanpa tahu kapan kamu akan kembali dan apakah kamu mau kembali
Saya ngga mungkin begini terus, melepas kepergian kamu, tanpa tahu kapan kamu akan kembali dan apakah kamu mau kembali
Tak seusia, bukan berarti tak sesuai
Tak perlu dua, cukup dia
Milea, kamu cantik, tapi aku belum mencintaimu, nggak tahu kalau sore. Tunggu aja
Cemburu itu hanya untuk orang yang nggak percaya diri. Dan sekarang aku sedang tidak percaya diri
Cinta Tidak Bisa Dipaksakan, Merelakannya Pergi Jauh Lebih Baik Daripada Menggenggamnya Tanpa Cinta
Ketika Tuhan mengambil sesuatu dari genggamanmu, Dia tak menghukummu, namun hanya membuka tanganmu tuk menerima yang lebih baik
Tidak penting saya berasal dari mana, tapi saya tahu kemana tujuan saya
Tuhan tidak pernah menciptakan produk gagal
Hanya orang bodoh yang mau kembali ke kebodohannya dan meninggalkan masa depannya
Ketika kita memimpin orang lain, kita lupa bertanya apakah kita sudah bisa memimpin diri sendiri
Sikap toleransi akan membingkai semua perbedaan dengan sempurna
Kamu bisa aja pergi dari masalah, tapi masalah tidak akan hilang dari hidup kamu
Apa gunanya punya pikiran sendiri, kalo lo selalu percaya ama pikiran orang`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}