$re = '/(?<host>[a-z0-9.\-_]+(?<port>:\d+)?\/)?(?<ns>[a-z]+\/)?(?<repo>[a-z\-])+:(?<tag>[\w.\-])+$/mi';
$str = 'alpine:3.7
pse/anabroker:latest
mysql/mysql-server:8.0.27
docker.example.com/gmr/alpine:3.7
docker.example.com:5000/gmr/alpine:latest
z86jw44v.mirror.aliyuncs.com/library/mysql:8.0.27
z86jw44v.mirror.aliyuncs.com/library/debian:stretch-slim';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);