package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\([^()]*\)|[^()\s])+`)
var str = `1*1 (10, 10) (5, 5)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}