$re = '/(?:\([^()]*\)|[^()\s])+/m';
$str = '1*1 (10, 10) (5, 5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);