$re = '/\s+\-\s+|\s+\[|\]/';
$str = '#artist# - #song# [#id#]
/ - | \\[|\\]/g
# or even better
/\\s+\\-\\s+|\\s+\\[|\\]/g
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);