re = /\s+\-\s+|\s+\[|\]/
str = '#artist# - #song# [#id#]
/ - | \\[|\\]/g
# or even better
/\\s+\\-\\s+|\\s+\\[|\\]/g
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end