package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s]*<\/body.*>[\s]*<\/html.*>[\s]*\Z`)
var str = `</body></html>
asdausdiausodiausn
</body>
</html>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}