$re = '/[\s]*<\/body.*>[\s]*<\/html.*>[\s]*\Z/mD';
$str = '</body></html>
asdausdiausodiausn
</body>
</html>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);