$re = '/(?<!\d)(?!333333(?!\d))\d{6}(?!\d)/m';
$str = '333333 123456 333333,123456!Vasya1234560000 Петя123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);