re = /(?<!\d)(?!333333(?!\d))\d{6}(?!\d)/m
str = '333333 123456 333333,123456!Vasya1234560000 Петя123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end