const regex = /^((?:\d(-|\s)?){11,12}[X\d])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\d(-|\\s)?){11,12}[X\\d])$', 'gm')
const str = `9-78820-5478022
9 78820 5478022
any spaces between numbers:
9 7 88 20 54 780 22
9788205478022`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}