// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:\d(-|\s)?){11,12}[X\d])$").unwrap();
let string = "9-78820-5478022
9 78820 5478022
any spaces between numbers:
9 7 88 20 54 780 22
9788205478022";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}