package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]*)(0*)(\d*)([a-zA-Z]*)$`)
var str = `fafsah000012fafaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}