$re = '/^([a-zA-Z]*)(0*)(\d*)([a-zA-Z]*)$/m';
$str = 'fafsah000012fafaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);