#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d\d\/\d\/\d\d\d\d"
Local $sString = "=! VANHOLLANO DUMAI!" & @CRLF & _
"" & @CRLF & _
" !12/5/2018 ! !07:26!" & @CRLF & _
"!Jl. Jend. Sudirman No. 183 Dumai " & @CRLF & _
"Hp. 08116252883 " & @CRLF & _
"IDN !" & @CRLF & _
"! !" & @CRLF & _
"!vbdumsdr01 ! !Novita !" & @CRLF & _
"!Cust. Name..: ! ! !" & @CRLF & _
"! !" & @CRLF & _
"!---------------------------------!" & @CRLF & _
"! 1! !SHOPPING BAG SMALL! ! 0!" & @CRLF & _
"! 2! !PALMIER ! ! 7,400!" & @CRLF & _
"! 1! !ROTI SISIR KELAPA ! ! 15,800!" & @CRLF & _
"! ! ! !" & @CRLF & _
"!---------------------------------!" & @CRLF & _
"!Subtotal ! ! 23,200!" & @CRLF & _
"!Total Discount ! ! 0!" & @CRLF & _
"!PB1 ! ! 2,320!" & @CRLF & _
"!Total ! ! 25,520!" & @CRLF & _
"" & @CRLF & _
"!Cash ! ! 50,500!" & @CRLF & _
"" & @CRLF & _
"!Change back (Cash) ! ! 24,980!" & @CRLF & _
"!=================================!" & @CRLF & _
"" & @CRLF & _
" ! PERIKSA KEMBALI!" & @CRLF & _
"!struk belanja dan uang kembalian !" & @CRLF & _
" !anda. Komplain hanya bisa!" & @CRLF & _
"!dilakukan saat transaksi di kasir!" & @CRLF & _
"" & @CRLF & _
" !Customer Service!" & @CRLF & _
" !SMS: 08117541984!" & @CRLF & _
" !PIN BB: 2B4DCF32!" & @CRLF & _
"" & @CRLF & _
" ! FOLLOW US!" & @CRLF & _
"!ig : vanhollanobakery_jnpgroup !" & @CRLF & _
" !www.jnp-g.com!" & @CRLF & _
" !Thank You!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")