# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d\d\/\d\/\d\d\d\d"
test_str = ("=! VANHOLLANO DUMAI!\n\n"
" !12/5/2018 ! !07:26!\n"
"!Jl. Jend. Sudirman No. 183 Dumai \n"
"Hp. 08116252883 \n"
"IDN !\n"
"! !\n"
"!vbdumsdr01 ! !Novita !\n"
"!Cust. Name..: ! ! !\n"
"! !\n"
"!---------------------------------!\n"
"! 1! !SHOPPING BAG SMALL! ! 0!\n"
"! 2! !PALMIER ! ! 7,400!\n"
"! 1! !ROTI SISIR KELAPA ! ! 15,800!\n"
"! ! ! !\n"
"!---------------------------------!\n"
"!Subtotal ! ! 23,200!\n"
"!Total Discount ! ! 0!\n"
"!PB1 ! ! 2,320!\n"
"!Total ! ! 25,520!\n\n"
"!Cash ! ! 50,500!\n\n"
"!Change back (Cash) ! ! 24,980!\n"
"!=================================!\n\n"
" ! PERIKSA KEMBALI!\n"
"!struk belanja dan uang kembalian !\n"
" !anda. Komplain hanya bisa!\n"
"!dilakukan saat transaksi di kasir!\n\n"
" !Customer Service!\n"
" !SMS: 08117541984!\n"
" !PIN BB: 2B4DCF32!\n\n"
" ! FOLLOW US!\n"
"!ig : vanhollanobakery_jnpgroup !\n"
" !www.jnp-g.com!\n"
" !Thank You!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.