const regex = /(^.+?)([\[\d{1,}\]]{1,})(\[.+\]$)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.+?)([\\[\\d{1,}\\]]{1,})(\\[.+\\]$)', 'i')
const str = `ReportTemplateGraphParameters[graph-wind-speed-correlation][0][y_id]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}