re = /(^.+?)([\[\d{1,}\]]{1,})(\[.+\]$)/i
str = 'ReportTemplateGraphParameters[graph-wind-speed-correlation][0][y_id]
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end