#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?:(?<!\S)(?:VON|VAN|DE)|\G(?!\A)\S+)\K\x20"
Local $sString = "HENRIETTA VON DER GRAAF" & @CRLF & _
"CAROLINE VAN OOSTEN DE WINKEL" & @CRLF & _
"MARC DE VRIES VAN JONG" & @CRLF & _
"ANNEKA VANHOVEN BAKKER" & @CRLF & _
"JOHN SMITH"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)