$re = '/(?:(?<!\S)(?:VON|VAN|DE)|\G(?!\A)\S+)\K\x20/im';
$str = 'HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
ANNEKA VANHOVEN BAKKER
JOHN SMITH';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;