package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\d+\.){3}\d+|(\d+\.){1,3}\*)$`)
var str = `blah
1.1.*
blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}