$re = '/^((\d+\.){3}\d+|(\d+\.){1,3}\*)$/m';
$str = 'blah
1.1.*
blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);