using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(```\w+)([\s\S]*?)(```)";
string input = @"
<en-rate
[maximum]=""5""
[feedback]=""['Bad', 'Ok', 'Good', 'Very Good', 'Excellent']""
[(value)]=""ratingValue""
(starsChange)=""previewValue = $event""
/>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}