$re = '/(```\w+)([\s\S]*?)(```)/';
$str = '
<en-rate
[maximum]="5"
[feedback]="[\'Bad\', \'Ok\', \'Good\', \'Very Good\', \'Excellent\']"
[(value)]="ratingValue"
(starsChange)="previewValue = $event"
/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);