using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z](?![a-z]))|([A-Z][a-z])";
string input = @"Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
K4ON(SO3)2ON(SO3)2
Mg3
Xe34A
MgOHOH
HHO
MgOHOH
KKKKONSOOOSOOOOMgNSOOOSOOO";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}